Now that Debian 4.0 is out, and I assume that the VPSs will keep running on 3.1, maybe this comment from debian.org (/News/2007/20070407) (Sorry, I'm not allowed to post URLs) might be interesting regarding updating:

In preparation for the upcoming release of Debian GNU/Linux 4.0 (codename etch), Debian GNU/Linux 3.1 will be moved to the oldstable part of the archive. Users who would like to continue using Debian GNU/Linux 3.1 are advised to update their /etc/apt/sources.list network source to refer to sarge instead of stable.

Bernhard