Results 1 to 3 of 3

Thread: unknown dynamic library pgsql.so ?

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member Newbie
    Join Date
    Jun 2007
    Posts
    4

    Default unknown dynamic library pgsql.so ?

    I get this when running php scripts from the command line:


    PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/pgsql.so' - libpq.so.3: cannot open shared object file: No such file or directory in Unknown on line 0


    The file '/usr/lib/php4/pgsql.so' does exist however.. ? Anyone have an idea how to fix this without disabling php warnings? Thanks,

    -dan

  2. #2
    Former employee Newbie
    Join Date
    Jul 2006
    Posts
    57

    Default

    You can stop this message by disabling loading of the pgsql module. The line to load the module will either be in /etc/php.d/pgsql.ini, /etc/php.ini, or in /usr/local/lib/php.ini.

    You don't need the pgsql module unless you need to connect to a pgsql database.

    --
    Spry Support

  3. #3
    Junior Member Newbie
    Join Date
    Jun 2007
    Posts
    4

    Default

    Yes it was in /etc/php.d/pgsql.ini . I had looked in /etc/php.ini and didn't see it. Thanks!

    -dan

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •