Results 1 to 2 of 2

Thread: RH9 - lockups when using more than two drives on IDE controllers

  1. #1
    Junior Member Newbie
    Join Date
    Jul 2007

    Default RH9 - lockups when using more than two drives on IDE controllers

    I have a server running Red Hat 9. When I inherited it, it had five hard drives in it: one boot drive, two in RAID 1 mounted at /home, and two others just hanging out (no RAID config, not mounted anywhere). The four data drives were on a two-channel Promise IDE controller (the running array on channel 1, the unused one on channel 0).

    Since then I've tried to start using the other two drives with no success. First was a RAID 5 config using all four drives, which led to random lockups. I got another controller card and put each drive on its own channel with no change. Then I replaced all four drives with new ones, and after that I replaced the original controller and all the IDE cables. (The present config is four drives on two 2-channel Promise IDE controllers.)

    So I've replaced all the hardware in the storage subsystem, but it still locks up when I try to start using a drive on the second controller. Typically, mkraid will run, but the system will lock up immediately after. The only way to get it back is a hard reset. But it's not always immediately after. I've seen it happen when formatting a new array (if it uses a disk on the second controller). And like I said, I ran a RAID 5 array on it semi-successfully for a while, just putting up with seemingly random lockups. The lockups are pretty solid... machine stops responding to the keyboard (except for numlock, which still works), and like I said the only way to get the system back is to reset it. Nothing in the logs.

    So as far as I can tell, it doesn't like using more than two data drives at a time, especially those on the second controller. Does anyone know why this would be? Is it a RH9 issue, or a hardware issue, like the motherboard or something?

    Thanks! Let me know if I've forgotten to include any important bits of data.

  2. #2
    Member Newbie
    Join Date
    Oct 2005


    I can't imagine it being a RH9 issue...Any reason you're still running RH9?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts