Results 1 to 5 of 5

Thread: mod_rewrite

  1. #1
    Junior Member Newbie
    Join Date
    Dec 2005
    Posts
    4

    Default mod_rewrite

    I don't think mod_rewrite is enabled on my vps. How do I enable this feature?

  2. #2
    StephenAtSpry
    Guest

    Default

    The cPanel servers are setup with mod_rewrite compiled and available by default. To activate it, put the following line in your .htaccess file (a .htaccess file will function for your whole site if you place it in the web root, or only for specific directories if you place it under a subdirectory):

    RewriteEngine On

    After that line you can put all of your "RewriteRule"s needed to make the voodoo-that-is-mod_rewrite work.

    A good reference on mod_rewrite can be found at: http://httpd.apache.org/docs/1.3/mod/mod_rewrite.html

  3. #3
    Junior Member Newbie
    Join Date
    Mar 2007
    Posts
    1

    Default

    I am pretty sure mod_rewrite is not enabled on my server. It was, but after restarting the server, it is not there anymore.

    I checked phpinfo - and it does not show in the Apache mod loads.

    How do I get it loaded/compiled again? I have been googling this for hours, and all I keep reading is "you must contact you host to have mod_rewrite compiled on your Apache server"

    But, everytime I contact Spry Support - they email me back saying my basic account does not include servers support and I have to do everything via SSH panel. That's fine. But I am getting very frustrated - and after paying over $100/month and getting told that I dont pay enough for help - it is even more frustrating.

    I have two possible solutions??

    1) Someone please point me in the right direction. I don't mind doing it myself. But I can't find any information on how to do it.

    2) Or I move to another host like hostforweb - where they are cheaper and DO GIVE YOU HELP!!!!! even on the basic server plans. (I know because I use them for some other sights - and I never have any problems there.)

    I am sorry - but I have been woking on this issue around the clock for 2 days and I am frustrated. I am getting internal server errors because mod_rewrite suddenly vanished and I cant figure out why, or how to get it back!

  4. #4
    Former Employee Power Poster
    Join Date
    Apr 2005
    Location
    Seattle, WA
    Posts
    140

    Default

    The mod_rewrite module does come installed in the CPanel setup we provide. There are several ways that it can be removed however. One way is through recompiling of Apache and PHP, which has two possibilities. The first is by having the recompiling modify the /usr/local/apache/conf/httpd.conf file such that the mod_rewrite module is no longer listed with lines of "LoadModule" and "AddModule". These lines are necessary in order to have Apache load the module dynamically. The second possibility is that the module was not included in the compiling process and thus the module is no longer present.

    The greatest likelyhood is that the lines are simply not present in the httpd.conf file. The two lines you should have present are:

    LoadModule rewrite_module libexec/mod_rewrite.so
    AddModule mod_rewrite.c

    If these lines aren't present, go ahead and add them. Then test to make sure the syntax of the file is correct by running "/usr/local/apache/bin/apachectl configtest". You should get "Syntax OK", otherwise it will tell you which lines have problems so you can fix it. Once the syntax is ok, you'll need to restart apache either through WHM or from the command line with "service httpd restart" to load the changes.

  5. #5
    Member Newbie
    Join Date
    Apr 2007
    Posts
    33

    Default

    Okay, this was quite a while ago, but it's what I am researching now . . . the link for the docs for mod_rewrite starts off by saying that Apache 1.3 is "no longer maintained" and "end of life"! So, is it safe to use EasyApache to update it? Will mod_rewrite (and, I suppose, everything else that's currently enabled) still BE there after that? What does Spry recommend?

    I'm not even sure it's what we need, yet. He wants to be able to have characters typed in before the actual domain name and get a certain page loaded.

    Hello, anyone there??

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •