The Virtuozzo system seems to have trouble seeding the entropy pool for /dev/random, this has a tendancy to cause Apache to not start because SSL is by default configured to use /dev/random. A workaround for this is to either remove /dev/random and symlink /dev/urandom (fake random, random enough for most things) to /dev/random. Your other option that dosen't affect the whole system is to modify your Apache SSL configuration with the following line:

SSLRandomSeed startup file:/dev/urandom 256

This will cause Apache to use the fake random device instead of the broken /dev/random device so it should start working properly.