Results 1 to 5 of 5

Thread: Problems upgrading from Plesk 8.3

  1. #1
    Junior Member Newbie Roeshead's Avatar
    Join Date
    Jun 2007
    Posts
    20

    Default Problems upgrading from Plesk 8.3

    I've got a brand new VPS Plesk 300 . Trying to upgrade the Plesk 8.3 to either 8.4 or 8.6, I got the message "Failed to check whether a new license key is available" so I did Parallels Article ID 3543 to fix that but now I continuously get:

    ERROR: PleskMainDBException

    MySQL query failed: MySQL server has gone away

    0: /usr/local/psa/admin/plib/common_func.php3:218
    db_query(string 'SELECT id, type, url, priority, enabled, auth_required, login, password FROM ai_vendor_sources')
    1: /usr/local/psa/admin/plib/autoinstaller/AutoInstallerVendorSource.php:136
    AutoInstallerVendorSource::getVendorSources()
    2: /usr/local/psa/admin/plib/autoinstaller/AutoInstallerManager.php:209
    AutoInstallerManager->install(string 'PLESK_8_4_0', array, boolean false, string 'XXXXX@domain.com', boolean true)
    3: /usr/local/psa/admin/htdocs/server/autoinstaller_install.php:101

    This is a brand new set-up done just today! I monitored the /var/log/mysqld.log for anything but nothing.

    Help! I got this new set-up because I'm trying to do a server migration so that I can upgrade my Plesk (my old server had gotten way too personalized for Plesk).

    Haven't found a solution on Parallels website either.

    Thanks.

  2. #2
    Junior Member Newbie Roeshead's Avatar
    Join Date
    Jun 2007
    Posts
    20

    Default

    I did a quick tail -f /tmp/autoinstaller3.log and a bunch of warnings came out: (sorry its so long but this is what came out - I had to shorten it to post but you get the picture of the warnings):

    Getting packages to installation list:
    Get packages to installation from selected component base
    (update package names cache) Get packages to installation from selected component psa-autoinstaller
    Get packages to installation from selected component api
    Following packages will be installed: courier-imap-3.0.8-cos5.build86080722.00.i586 plesk-skins-8.6.0-0.97326.noarch psa-8.6.0-cos5.build86080722.00.i586 psa-api-8.6.0-cos5.build86080822.20.noarch psa-awstats-configurator-1.0.0-cos5.build86080722.00.noarch psa-courier-imap-add-8.6.0-cos5.build86080722.00.i586 psa-horde-3.1.7-cos5.build86080722.00.noarch psa-hotfix3-8.6.0-cos5.build86080822.20.i586 psa-hotfix4-8.6.0-8.6.0-cos5.build86080910.19.i586 psa-imp-4.1.6-cos5.build86080722.00.noarch psa-ingo-1.1.5-cos5.build86080722.00.noarch psa-kronolith-2.1.8-cos5.build86080722.00.noarch psa-libpam-plesk-8.6.0-cos5.build86080722.00.i586 psa-locale-base-en-US-8.6.0-cos5.build86080722.00.noarch psa-logrotate-3.7-cos5.build86080722.00.i586 psa-mimp-1.0.2-cos5.build86080722.00.noarch psa-mnemo-2.1.2-cos5.build86080722.00.noarch psa-passwd-3.0.1-cos5.build86080722.00.noarch psa-proftpd-1.3.1-cos5.build86080722.00.i586 psa-proftpd-xinetd-1.3.1-cos5.build86080722.00.i586 psa-pylibplesk-8.6.0-cos5.build86080722.00.i586 psa-qmail-1.03-cos5.build86080822.20.i586 psa-selinux-8.6.0-cos5.build86080722.00.noarch psa-turba-2.1.7-cos5.build86080722.00.noarch psa-updates-8.6.0-cos5.build86080910.19.noarch psa-autoinstaller-3.3.2-080710.09.i386 psa-api-rpc-8.6.0-cos5.build86080822.20.noarch
    ----------------
    Regenerate packages provides cache.
    PkgManager: start to resolving packages
    findNecessaryPackages(): start pass 0
    Find directly required packages for courier-imap-3.0.8-cos5.build86080722.00.i586
    (regen conflicts cache) Warning: packages conflict by files detected: package libxslt-1.1.17-2.i386
    conflict with package libxslt-1.1.17-2.el5_2.2.i386
    both have file /usr/bin/xsltproc with different md5 sum.
    Warning: packages conflict by files detected: package psmisc-22.2-5.i386
    conflict with package psmisc-22.2-6.i386
    both have file /sbin/fuser with different md5 sum.
    Warning: packages conflict by files detected: package libgcc-4.1.2-14.el5.i386
    conflict with package libgcc-4.1.2-42.el5.i386
    both have file /lib/libgcc_s.so.1 with different md5 sum.
    Warning: packages conflict by files detected: package glibc-2.5-18.el5_1.1.i686
    conflict with package glibc-2.5-24.i686
    both have file /lib/i686/nosegneg/libc-2.5.so with different md5 sum.
    Warning: packages conflict by files detected: package glibc-2.5-18.el5_1.1.i686
    conflict with package glibc-2.5-24.i386
    both have file /lib/ld-2.5.so with different md5 sum.
    Warning: packages conflict by files detected: package cups-libs-1:1.2.4-11.14.el5_1.3.i386
    conflict with package cups-libs-1:1.2.4-11.18.el5_2.1.i386
    both have file /usr/lib/libcups.so.2 with different md5 sum.
    Warning: packages conflict by files detected: package glibc-devel-2.5-18.el5_1.1.i386
    conflict with package glibc-devel-2.5-24.i386
    both have file /usr/lib/Mcrt1.o with different md5 sum.
    Warning: packages conflict by files detected: package gcc-4.1.2-14.el5.i386
    conflict with package gcc-4.1.2-42.el5.i386
    both have file /usr/bin/gcc with different md5 sum.
    Warning: packages conflict by files detected: package libselinux-1.33.4-4.el5.i386
    conflict with package libselinux-1.33.4-5.el5.i386
    both have file /lib/libselinux.so.1 with different md5 sum.
    Warning: packages conflict by files detected: package krb5-libs-1.6.1-17.el5.i386
    conflict with package krb5-libs-1.6.1-25.el5.i386
    both have file /usr/lib/libdes425.so.3.0 with different md5 sum.
    Warning: packages conflict by files detected: package initscripts-8.45.17.EL-1.el5.centos.1.i386
    conflict with package initscripts-8.45.19.EL-1.el5.centos.1.i386
    both have file /bin/doexec with different md5 sum.
    Warning: packages conflict by files detected: package libselinux-python-1.33.4-4.el5.i386
    conflict with package libselinux-python-1.33.4-5.el5.i386
    both have file /usr/lib/python2.4/site-packages/_selinux.so with different md5 sum.
    Warning: packages conflict by files detected: package samba-swat-0:3.0.25b-1.el5_1.4.i386
    conflict with package samba-swat-0:3.0.28-1.el5_2.1.i386
    both have file /usr/sbin/swat with different md5 sum.
    Warning: packages conflict by files detected: package samba-client-0:3.0.25b-1.el5_1.4.i386
    conflict with package samba-client-0:3.0.28-1.el5_2.1.i386
    both have file /sbin/mount.cifs with different md5 sum.
    Warning: packages conflict by files detected: package rpm-python-4.4.2-47.el5.i386
    conflict with package rpm-python-4.4.2-48.el5.i386
    both have file /usr/lib/python2.4/site-packages/rpm/__init__.pyc with different md5 sum.
    Warning: packages conflict by files detected: package caching-nameserver-30:9.3.3-10.el5.i386
    conflict with package caching-nameserver-30:9.3.4-6.0.2.P1.el5_2.i386
    both have file /etc/named.caching-nameserver.conf with different md5 sum.
    Warning: packages conflict by files detected: package psa-selinux-8.3.0-cos5.build83071219.16.noarch
    conflict with package psa-selinux-8.6.0-cos5.build86080722.00.noarch
    both have file /usr/local/psa/etc/plesk.pp with different md5 sum.
    Warning: packages conflict by files detected: package mysql-5.0.22-2.2.el5_1.1.i386
    conflict with package mysql-5.0.45-7.el5.i386
    both have file /etc/my.cnf with different md5 sum.
    Warning: packages conflict by files detected: package mysql-5.0.22-2.2.el5_1.1.i386
    conflict with package mysql-server-5.0.45-7.el5.i386
    both have file /usr/bin/mysqldumpslow with different md5 sum.
    Warning: packages conflict by files detected: package mysql-server-5.0.22-2.2.el5_1.1.i386
    conflict with package mysql-server-5.0.45-7.el5.i386
    both have file /etc/rc.d/init.d/mysqld with different md5 sum.
    Warning: packages conflict by files detected: package mysql-server-5.0.22-2.2.el5_1.1.i386
    conflict with package mysql-5.0.45-7.el5.i386
    both have file /usr/bin/my_print_defaults with different md5 sum.
    Warning: packages conflict by files detected: package php-mbstring-5.1.6-15.el5.i386
    conflict with package php-mbstring-5.1.6-20.el5_2.1.i386
    both have file /usr/lib/php/modules/mbstring.so with different md5 sum.
    Warning: packages conflict by files detected: package php-pdo-5.1.6-15.el5.i386
    conflict with package php-pdo-5.1.6-20.el5_2.1.i386
    both have file /usr/lib/php/modules/pdo.so with different md5 sum.
    Warning: packages conflict by files detected: package psa-kronolith-2.1.6-cos5.build83071218.19.noarch
    conflict with package psa-kronolith-2.1.8-cos5.build86080722.00.noarch
    both have file /usr/share/psa-horde/kronolith/addevent.php with different md5 sum.
    Warning: packages conflict by files detected: package psa-turba-2.1.5-cos5.build83071218.19.noarch
    conflict with package psa-turba-2.1.7-cos5.build86080722.00.noarch
    both have file /usr/share/psa-horde/turba/browse.php with different md5 sum.
    Warning: packages conflict by files detected: package perl-DBI-1.601-1.el5.rf.i386
    conflict with package perl-DBI-1.52-1.fc6.i386
    both have file /usr/bin/dbiprof with different md5 sum.

  3. #3
    Junior Member Newbie
    Join Date
    Sep 2008
    Posts
    1

    Default

    Please submit a support ticket and we can fix this for you.

  4. #4
    Forum Administrator Power Poster Lyle@Spry's Avatar
    Join Date
    May 2005
    Posts
    455

    Default

    MySQL server has gone away
    can be caused by too short of a timeout setting in /etc/my.cnf. (MySQL killing off a query taking longer than the timeout setting will trigger this error in the Plesk updater.)

    If you edit /etc/my.cnf, and comment out any line that specifies timeout and restart MySQL (service mysqld restart), the Plesk updater should be able to continue.

  5. #5
    Junior Member Newbie Roeshead's Avatar
    Join Date
    Jun 2007
    Posts
    20

    Default

    You're on fire today, Lyle.

    You got it right (and I couldn't find this posted anywhere). In the my.cnf file was a 'wait_timeout=10'. Took it out and upgrades are flying.

    Thanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •