Results 1 to 2 of 2

Thread: php5.26 include/require error

  1. #1
    Junior Member Newbie
    Join Date
    Mar 2008
    Posts
    4

    Default php5.26 include/require error

    We updata vps to php5.26 with Easy::Apache v3.2.0 Build 4523
    we get include error

    Warning: require(/home/clicks/public_html/inc/frame/frame.php) [function.require]: failed to open stream: Permission denied in /home/abruzzo3/public_html/inc/frame.php on line 2

    Fatal error: require() [function.require]: Failed opening required '/home/clicks/public_html/inc/frame/frame.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/abruzzo3/public_html/inc/frame.php on line 2

    How can we fix this?

  2. #2
    Senior Member Power Poster
    Join Date
    Dec 2007
    Posts
    359

    Default

    You will need to change the permissions on the /home/clicks/public_html/inc/frame/frame.php file - here is what you should do from an SSH session:

    • Run ls -la /home/clicks/public_html/inc/frame/frame.php to see what the present permissions are for the file (see this ls guide or run man ls for details on using ls)
    • Run chmod 755 /home/clicks/public_html/inc/frame/frame.php (replace 755 with the appropriate permissions if necessary - see this chmod guide or run man chmod for details on using chmod)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •