I'm running several php/mysql apps which I think is causing some memory issues. I'm kinda new to administrating linux servers so I hope I'm reading my data right.

In the user_beancounters, I'm seeing failcnt high for privvmpages . My normal memory levels are usually taking up almost all of my RAM but the swap was always zero so I thought everything was good in the memory area. Today I realized that there was no swap (doing a free command). I tried setting up a swap by doing a "dd" to create the swap file, then mkswap and then tried to do a "swapon" with the file only to get "Operation not permitted". So I thought I would go ahead and add a line for the swap in the /etc/fstab and then rebooted the VPS thinking that would put the swap file to work. Nope, the free command still showed no swap file. I then thought I should look at the /proc/swaps only to find that there is no swaps file (but there is a /proc directory).

Help - how do I get the swap stuff working on my VPS?

PS - I have a VPS300 using a Plesk control panel if that makes a difference.

Thanks so much for any help.