Results 1 to 4 of 4

Thread: Requirements needed

  1. #1
    Junior Member Newbie
    Join Date
    Jan 2006
    Posts
    2

    Question Requirements needed

    I am taking the short cut here and asking if these programs/scripts are currently available.

    *nix web server - this has been tested on Redhat and should work on any *nix server.
    MySQL Server 4.1+ (Email Us if you need a us to host your database)
    perl 5.8
    CGI and LWP perl modules
    DBI perl modules for MYSQL access
    Image::Magick perl module and ImageMagick (Min version 6, we know it works for ImageMagick version 6.2.x)
    Digest::MD5 and Image::Info perl modules

  2. #2
    StephenAtSpry
    Guest

    Default

    I don't quite know what you mean by "*nix web server", but all of our systems ship with Apache (I think debians ship with Apache 2). MySQL is usually the last 3.x release, but can be upgraded if you require the complexity of 4.1. Perl is 5.8.7 on most systems. ImageMagick isn't included by default on any of our systems (if I recall correctly), but can be installed. Any perl modules that aren't part of the base system can be installed with CPAN.

    The thing about a VPS is that if it's not configured the way you want, you can change the configuration. You're not stuck in a shared hosting world anymore. You can run whatever software you need.

  3. #3
    Junior Member Newbie
    Join Date
    Mar 2006
    Posts
    2

    Default Regarding Imagemagick

    Hello, I have attemped to install ImageMagick various times and all have been unsuccessfull. I must admit that Im quite new to this system. I just recently setup up the nameservers (my websites are down). When I try to install imagemagick, I get various errors,
    Code:
    [root@server usr]# rpm -i ImageMagick-6.2.6-4.i386.rpm
    /etc/security/selinux/file_contexts: No such file or directory
    error: Failed dependencies:
            libICE.so.6 is needed by ImageMagick-6.2.6-4
            libSM.so.6 is needed by ImageMagick-6.2.6-4
            libX11.so.6 is needed by ImageMagick-6.2.6-4
            libXext.so.6 is needed by ImageMagick-6.2.6-4
            libXt.so.6 is needed by ImageMagick-6.2.6-4
            liblcms.so.1 is needed by ImageMagick-6.2.6-4
            libwmflite-0.2.so.7 is needed by ImageMagick-6.2.6-4
    Therefore, I need to have those installed, and what is wrong with the NO such file? Thanks

  4. #4
    Junior Member Newbie
    Join Date
    Apr 2006
    Posts
    25

    Default

    It looks like you didn't upload the files to the correct path. If this isn't the case, maybe you will find this install guide useful: http://www.photopost.com/howtoinstall-php.html and if that doesn't help I would recommend googling for it with a phrase like "install guide for ImageMagick on unix".
    Last edited by winchester; 04-23-2006 at 06:23 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •