Results 1 to 5 of 5

Thread: set abuse and or postermaster for all domains

  1. #1
    Member Newbie
    Join Date
    Apr 2005
    Location
    Long Island NY
    Posts
    43

    Default set abuse and or postermaster for all domains

    I can't find this info, I know I saw it somewhere..

    Fedora Core 4 running cpanel & Exim 4.52

    Where do I globally set postmaster@ and abuse@
    Right now both bounce as user unknown. AOL is getting strickter and stricter and I need to set both so I can submit for a feedback loop on the new server.

  2. #2
    Junior Member Newbie
    Join Date
    Aug 2005
    Posts
    28

    Default

    I see that no qualified experts are showing up, so here's some info from an amateur (my VPS is Fedora, but doesn't use Exim or cpanel):

    Does your /etc/exim/exim.conf file have the following?

    system_aliases:
    driver = aliasfile
    file_transport = address_file
    pipe_transport = address_pipe
    file = /etc/aliases

    if so, then you should be able to configure global "postmaster" and "abuse" aliases in the "/etc/aliases" file, which is standard acrosss many different platform/software combinations. Traditionally, both are aliased to "root" like this:

    postmaster: root
    abuse: root

    but you might want to specifically direct them off server to another address:

    postmaster: userid@foo.bar
    abuse: another@foo.bar

    Once you've edited the aliases file, you need to issue a "newaliases" command while SSH'd in as root.

    Sorry if this isn't helpful in your situation, but it's standard in all other server situations I've encountered.

    DT

  3. #3
    Member Newbie
    Join Date
    Apr 2005
    Location
    Long Island NY
    Posts
    43

    Default

    Thanks DT I will give that a whirl later and let you know

  4. #4
    Member Newbie
    Join Date
    Apr 2005
    Location
    Long Island NY
    Posts
    43

    Default

    Alrighty then.. I looked and while the lines were slightly different, they were there:

    system_aliases:
    driver = redirect
    allow_defer
    allow_fail
    data = ${lookup{$local_part}lsearch{/etc/aliases}}
    file_transport = address_file
    pipe_transport = address_pipe
    retry_use_local_part


    So now I poked into the /etc/alias file and indeed, postmater & abuse are piped to root.. but I get neither..

    # Basic system aliases -- these MUST be present.
    mailer-daemon: postmaster
    postmaster: root
    [snip]
    abuse: root

    Recipient address: abuse@mydomain_on_server.com
    Reason: Remote SMTP server has rejected address
    Diagnostic code: smtp;550-"The recipient cannot be verified. Please check all recipients of this message to verify they are valid."


    Recipient address: postmaster@the_main_domain_on_server.com
    Reason: Remote SMTP server has rejected address
    Diagnostic code: smtp;550-"The recipient cannot be verified. Please check all recipients of this message to verify they are valid."

    in the WHM > Server Contacts > Change System Mail Preferences
    root is set to go to my off server address

    Open to suggestions here..

  5. #5
    Junior Member Newbie
    Join Date
    Aug 2005
    Posts
    28

    Default

    Sorry, but I don't know anything about exim, so instead of waiting around here, I'd suggest heading for some forums, or other sites:

    http://www.nabble.com/Exim-f13822.html

    or the Technical & Security Issues forum at WHT:

    http://www.webhostingtalk.com/forumdisplay.php?f=5

    or
    FAQ, mailing list, etc:
    http://www.exim.org/

    DT

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •