Ok, so, long story short. I have a CentOS 5.8 VPS running WHM/cPanel and I used the MySQL upgrade link in WHM. Went from 5.0.x to 5.1.x and it was really easy. Figured MySQL 5.5.x was listed so it must be a good idea to upgrade. Needless to say my server melted down.

The Spry paid support guys were able to get 5.0.x installed for me and get me running, but everywhere that shows what version of MySQL you're running shows 5.5.x. Any clue how to change it so I can again upgrade to 5.1.x?

Any help is greatly appreciated.

Matt