Results 1 to 3 of 3

Thread: Can't upgrade glibc on webmin/CentOS

  1. #1
    Junior Member Newbie
    Join Date
    Jan 2007
    Posts
    1

    Default Can't upgrade glibc on webmin/CentOS

    Trying to upgrade a new webmin vps server to CentOS 4.4., the upgrade fails when trying to get the new glibc packages:

    <snip>
    --> Running transaction check
    --> Processing Dependency: glibc-common = 2.3.4-2.19 for package: glibc-dummy-centos-4
    --> Finished Dependency Resolution
    Error: Missing Dependency: glibc-common = 2.3.4-2.19 is needed by package glibc-dummy-centos-4

    I went ahead and upgraded the remaining packages, just wondering if anyone has run into the same problem with glibc.

    Here's a bit more info:

    [qleroy@magilla ~]$ rpm -q glibc glibc-common glibc-dummy-centos-4
    glibc-2.3.4-2.19.i686
    glibc-common-2.3.4-2.19.i386
    glibc-dummy-centos-4-2.3.4-2.19.swsoft.i386

    My guess is the problem is related to webmin.

    Thx!

  2. #2
    Former Employee Newbie
    Join Date
    Nov 2005
    Posts
    56

    Default

    It should be possible to work around this by adding the following to yum.conf under [main]:
    exclude=glibc*

  3. #3
    Junior Member Newbie
    Join Date
    Oct 2006
    Posts
    3

    Default

    I don't have webmin. I use cpanel and I experienced the same problem. I followed spry_joseph advice's and I was able to upgrade to CentOS 4.4

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •